Intermittent Latency Issues with 3rd party communication provider (PubNub)

Incident Report for Chapter One

Resolved

From PubNub: With no further issues observed, the incident has been resolved. We will follow up soon with a root cause analysis.
Posted Jun 30, 2025 - 15:18 UTC

Monitoring

We experienced elevated latency and intermittent connection issues with PubNub services in the FRA (Europe) region on Monday morning, following a similar service disruption last Friday. Latency began returning to normal around 9:45 AM BST, and PubNub marked the issue as resolved by approximately 10:30 AM BST.

Incident report: https://status.pubnub.com/incidents/nrkfvxdhmgmf

A second latency spike occurred later in the afternoon. While the issue was again listed under the FRA region, we also observed an impact on users in North America. As with the earlier incident, increased latency was visible on PubNub’s status graphs before the issue was formally acknowledged.

Afternoon incident report: https://status.pubnub.com/incidents/dfn659gyzg1m

As of 2:45 PM BST, latency levels have returned to baseline. We have contacted PubNub for more information regarding the root cause and remediation efforts and will update this page when we receive a response.
Posted Jun 30, 2025 - 15:16 UTC
This incident affected: Online Reading Volunteer Platform (ORV) (Video / Audio Sessions).