Platform slowdown related to AWS outage

Incident Report for Chapter One

Resolved

Server stability has improved. While AWS is working on resolving residual issues from their outage earlier, we do not suspect any more degraded performance issues across the Chapter One applications.
Posted Oct 20, 2025 - 20:08 UTC

Monitoring

We are monitoring performance issues stemming from this morning’s AWS outage. Some users may experience longer than normal loading times. Normal service will resume once AWS completes their recovery. Further updates will be provided if needed.
Posted Oct 20, 2025 - 16:46 UTC
This incident affected: High-Impact Tutoring Platform (HIT) (ELI Instructional Platform, Student Platform Activities & Games), Online Reading Volunteer Platform (ORV) (Live Support, Video / Audio Sessions), and Global Free Library, Reports.