Some users are experiencing 503 errors on the platform, or long loading times.

Incident Report for Chapter One

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 14:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2025 - 14:10 UTC

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 13:41 UTC

Investigating

We are currently investigating this issue.
Posted Jun 20, 2025 - 13:33 UTC
This incident affected: Online Reading Volunteer Platform (ORV) (Video / Audio Sessions).